目前RN项目中package.json中的三方库结合使用HarmonyOS里的package.json 的配置出现npm i不过的情况

目前RN项目中package.json中的三方库结合使用HarmonyOS里的package.json 的配置出现npm i不过的情况

HarmonyOS
2024-05-11 15:21:11
浏览
收藏 0
回答 1
待解决
回答 1
按赞同
/
按时间
fiftystep

使用了社区上比较老版本的viewpager,库依赖"react": “^16.0”,但是react-native-harmony依赖18的版本,两个版本冲突导致的报错。通过强制安装就可以解决报错,npm install – force。后续建议使用到的三方库也更新到最新版本HarmonyOS版本

分享
微博
QQ
微信
回复
9天前
相关问题
HarmonyOS支持三方列表
142浏览 • 1回复 待解决
react-native 第三方使用npm更新
159浏览 • 1回复 待解决
如何本地依赖非适配HarmonyOS三方
141浏览 • 1回复 待解决
js API8 如何使用项目中npm包?
1495浏览 • 1回复 待解决
Native工程如何使用其他三方so
441浏览 • 1回复 待解决
如何获取可用三方
307浏览 • 1回复 待解决
实现弹幕功能三方
154浏览 • 1回复 待解决
ArkTS不支持使用三方js
1914浏览 • 1回复 待解决
有图片加载三方么?
139浏览 • 1回复 待解决
是否有支持非对称加密三方
183浏览 • 1回复 待解决
三方中心仓reflect-metadata问题
108浏览 • 1回复 待解决
怎么使用pdfjs三方预览pdf文档
182浏览 • 1回复 待解决
应用内 FFmpeg 开源三方编译
160浏览 • 1回复 待解决