DevEco Studio升级到NEXT Developer Preview1版本后工程编译不过

IDE更新到此版本后,会强制使用HarmonyOS Next SDK,该版本SDK可能存在和工程不兼容的情况,此时需要使用之前可以使用的SDK进行替换。


HarmonyOS
2024-06-13 11:25:16
浏览
已于2024-6-13 11:27:44修改
收藏 0
回答 1
待解决
回答 1
按赞同
/
按时间
put_get

替换步骤

1. 打开SDK所在目录,路径可以在IDE设置中找到。

2. 之前的目录结构与现在不同,需要替换指定文件夹内容。

3. 打开hmscore文件夹,选择可以使用的版本,打开该版本文件夹,将文件夹中的四个子文件夹复制到HarmonyOS-NEXT-DP1\hms目录下。

4. 打开openharmony文件夹,选择可以使用的版本,打开该版本文件夹,将文件夹中的五个子文件夹复制到HarmonyOS-NEXT-DP1\base目录下。

5. 重启IDE即可正常编译。

分享
微博
QQ
微信
回复
2024-06-13 22:50:12
相关问题
升级到next,oaid是否会变?
552浏览 • 1回复 待解决
mate30 5G鸿蒙110版本更新升级150版本
6367浏览 • 1回复 待解决
DevEco Studio新建工程编译报错
2637浏览 • 0回复 待解决
HarmonyOS NEXT Developer Beta1模拟器闪退
240浏览 • 1回复 待解决
android 应用升级到鸿蒙应用
1539浏览 • 0回复 待解决
2.1.1版本的axios发post请求会报401
502浏览 • 1回复 待解决
什么时候优化更新到鸿蒙222版本
4063浏览 • 1回复 待解决
Open Harmony 3.1版本支持横竖屏切换吗?
3841浏览 • 1回复 待解决
DevEco Studio 升级的一些问题
8832浏览 • 1回复 待解决