API 版本适配config.json

如何进行配置config.json文件的版本适配,

如:文件中配置了API 6新特性

{

        "name": "ohos.data.file.FileAbility",

         "icon": "$media:icon",

         "description": "$string:fileability_description",

        "type": "data",

        "uri": "dataability://ohos.data.file.FileAbility",

        "grantPermission": true

},

同时编译版本和兼容最低版本

compileSdkVersion 6
defaultConfig {
    compatibleSdkVersion 5
},

 

如何添加相关配置使应用能在API 5的设备上正常运行

 

版本适配
2021-08-31 18:17:50
浏览
收藏 0
回答 1
待解决
回答 1
按赞同
/
按时间
候鹏飞
2

现在所有的手机的版本为api5, 等手机版本更新,现有远程真机模拟器Mate30可以使用API6。

分享
微博
QQ
微信
回复1
2021-08-31 21:37:28
相关问题
如何调用config.json中的数据项
3548浏览 • 2回复 待解决
js api 如何读取预置的json文件?
1379浏览 • 1回复 待解决
鸿蒙手机屏幕怎么适配
3609浏览 • 1回复 待解决
Failure[INSTALL_FAILED_BUNDLE_INFO_NOT_CONFIG]
685浏览 • 1回复 待解决
resource中string.json的用法?
2371浏览 • 1回复 已解决
硬件设备如何适配HarmonyOS?
5152浏览 • 1回复 待解决
有关FA的多端适配问题
1936浏览 • 1回复 待解决
鸿蒙pattern.json怎么使用?
3050浏览 • 4回复 待解决
能不能让鸿蒙再早一点适配荣耀
1655浏览 • 4回复 待解决
鸿蒙目前适配哪些开发板?
7255浏览 • 1回复 已解决
关于Hi3861硬件子系统&SDK适配
3406浏览 • 5回复 已解决
鸿蒙生态中有没有react-native适配
4069浏览 • 1回复 待解决