一个鸿蒙JS项目compatibleSdkVersion 是5,引入api6和7支持的功能,在api 5的手机上直接报错,如何解决?

如题,报错信息 ReferenceError: requireNapi is not defined,如何做好这种适配
 

鸿蒙
JS
compatibleSdkVer
2021-12-31 15:31:07
浏览
收藏 0
回答 1
待解决
回答 1
按赞同
/
按时间
Bowma

手机系统升级到能够适配的版本,比如要用api6的功能,手机系统api最低要6。查看api版本hdc shell getprop hw_sc.build.os.apiversion

分享
微博
QQ
微信
回复
2021-12-31 17:45:19
相关问题
space-betweenapi6 下不生效问题
4155浏览 • 1回复 待解决
API6SDK 如何下载?
599浏览 • 1回复 待解决
鸿蒙软总线nearbyService5问题
4800浏览 • 1回复 待解决
鸿蒙JS API7新增接口在哪里
3673浏览 • 1回复 待解决
开发Wearable应用只能用api6
1481浏览 • 2回复 待解决
api6如何实现点击桌面卡片弹出提示
1184浏览 • 1回复 待解决
HarmonyOS 3.0支持 MediaProjectionManager吗?
1557浏览 • 1回复 待解决
Openharmony HI3861支持文件操作吗?
1651浏览 • 1回复 已解决
js API8 如何使用项目npm包?
1351浏览 • 1回复 待解决
harmonyOS4.0手机,对应api9不?
624浏览 • 1回复 待解决
虚拟机上运行不了鸿蒙项目
4612浏览 • 1回复 待解决
openharmony etsjs Api能否实现通用
3719浏览 • 1回复 待解决