3516开发板安装OpenHarmony3.1 hdc工具无法正常使用

3516开发板安装OpenHarmony3.1 hdc工具无法正常使用-开源基础软件社区如图,可以看到设备已经正常连接,但是执行命令无响应

尝试了 hdc kill -r 也无法解决

3.1 hdc工具
2022-04-02 16:01:54
浏览
收藏 0
回答 1
已解决
回答 1
按赞同
/
按时间
Joshun
1

工具使用过程中碰到问题,可以参考如下流程自助排查:

step1: 先检查pc(host)端hdc_std 和L2设备端hdcd版本是否一致(-v 查看版本):step1a: 版本不一致请更新使用一致版本再验证;
step1b: 版本一致请继续下面排查step2步骤;
step2: 检查pc(host)端设备管理器设备信息是否正常(设备是否正常加载显示、驱动、id是否正常):step2a: 设备管理器设备异常或无设备, 请结合板测试设备端串口下确认下usb部分设备枚举上报是否异常;
step2b: 设备管理器设备正常时, 1)list targets 是否正常;2)hdc_std kill 后重试是否正常;
注意:客户端和设备端版本保持一致(hdc_std -v,hdcd -v参数查看版本)!

 

解决方法来自:https://gitee.com/openharmony/developtools_hdc_standard

分享
微博
QQ
微信
回复1
2022-04-06 15:14:58
相关问题
3516开发板使用编译使用mqtt?
3127浏览 • 2回复 待解决
无法正常使用开发工具Pycharm
25362浏览 • 46回复 已解决
DOPI Hi3516EV200开发板无法刷鸿蒙系统
4144浏览 • 3回复 待解决
开发工具安装完成,无法打卡
2652浏览 • 1回复 待解决
HarmonyOS支持其他开发板吗?
8874浏览 • 4回复 待解决
鸿蒙目前适配哪些开发板
7289浏览 • 1回复 已解决
请问怎么获取HarmonyOS的开发板
12298浏览 • 8回复 待解决
鸿蒙开发板Hi3861烧录报错?
5396浏览 • 3回复 待解决
针对Windows system32 无法正常安装
1438浏览 • 1回复 待解决
安装开发工具安装js依赖失败
5052浏览 • 1回复 待解决
开发板推荐或购买链接
3671浏览 • 2回复 已解决