Ubuntu 20.04编译Openharmony3.2环境配置出错

vmware虚拟机安装的64位ubuntu20.04, 按照openharmony官网配置环境,


1.安装库和工具集

参照 ​​https://gitee.com/openharmony/docs/blob/master/zh-cn/device-dev/quick-start/quickstart-pkg-install-package.md​​ ,使用如下apt-get命令安装后续操作所需的库和工具,


$sudo apt-get update && sudo apt-get install binutils binutils-dev git git-lfs gnupg flex bison gperf build-essential zip curl zlib1g-dev gcc-multilib g++-multilib gcc-arm-linux-gnueabi libc6-dev-i386 libc6-dev-amd64 lib32ncurses5-dev x11proto-core-dev libx11-dev lib32z1-dev ccache libgl1-mesa-dev libxml2-utils xsltproc unzip m4 bc gnutls-bin python3.8 python3-pip ruby genext2fs device-tree-compiler make libffi-dev e2fsprogs pkg-config perl openssl libssl-dev libelf-dev libdwarf-dev u-boot-tools mtd-utils cpio doxygen liblz4-tool openjdk-8-jre gcc g++ texinfo dosfstools mtools default-jre default-jdk libncurses5 apt-utils wget scons python3.8-distutils tar rsync git-core libxml2-dev lib32z-dev grsync xxd libglib2.0-dev libpixman-1-dev kmod jfsutils reiserfsprogs xfsprogs squashfs-tools pcmciautils quota ppp libtinfo-dev libtinfo5 libncurses5-dev libncursesw5 libstdc++6 gcc-arm-none-eabi vim ssh locales libxinerama-dev libxcursor-dev libxrandr-dev libxi-dev


这样操作后会报错,如下,



The following packages have unmet dependencies:

g++ : Depends: g++-9 (>= 9.3.0-3~) but it is not going to be installed

      Depends: gcc-9 (>= 9.3.0-3~) but it is not going to be installed

g++-multilib : Depends: g++-9-multilib (>= 9.3.0-3~) but it is not going to be installed

gcc : Depends: gcc-9 (>= 9.3.0-3~) but it is not going to be installed

gcc-arm-linux-gnueabi : Depends: gcc-9-arm-linux-gnueabi (>= 9.3.0-3~)

gcc-multilib : Depends: gcc-9-multilib (>= 9.3.0-3~) but it is not going to be installed

lib32ncurses-dev : Depends: lib32ncurses6 (= 6.2-0ubuntu2) but it is not going to be installed

                   Depends: lib32ncursesw6 (= 6.2-0ubuntu2) but it is not going to be installed

                   Depends: lib32tinfo6 (= 6.2-0ubuntu2) but it is not going to be installed

lib32z1-dev : Depends: lib32z1 (= 1:1.2.11.dfsg-2ubuntu1.5) but it is not going to be installed

libc6-dev-i386 : Depends: libc6-i386 (= 2.31-0ubuntu9.9) but it is not going to be installed

libx11-dev : Depends: libx11-6 (= 2:1.6.9-2ubuntu1.2) but 2:1.6.9-2ubuntu1.3 is to be installed

E: Unable to correct problems, you have held broken packages.


这个问题谁遇到过,哪位大神知道指导一下,谢谢!

openharmony
2023-02-02 16:15:38
浏览
收藏 1
回答 0
待解决
相关问题
hi3861环境编译出现编码问题
9690浏览 • 1回复 待解决
openharmony3.2 Relese 静态IP
992浏览 • 0回复 待解决
OpenHarmony 3.2 LTS版本发布计划
6482浏览 • 1回复 已解决
hispar开发套件环境配置编译出现问题
266浏览 • 0回复 待解决
MQTT为什么编译出错啊?
712浏览 • 1回复 待解决
搭建鸿蒙环境时,编译报错
9346浏览 • 3回复 待解决
DevEco Studio 2.1.0.501 x64配置SDK出错
5009浏览 • 2回复 待解决
小熊派智慧物流案例编译出错
3624浏览 • 1回复 待解决
导入HI3861工程之后编译出错
4098浏览 • 1回复 待解决
OpenHarmony dcts无法编译通过
1457浏览 • 0回复 待解决
repo+https下载openharmony2.2出错,求助
4351浏览 • 1回复 待解决
求助:Ubuntu编译w800时遇到问题。
4077浏览 • 1回复 待解决