用鸿蒙DevEco Studio3.1.1开发,仿真错误

昨天开始学习鸿蒙开发,使用DevEco Studio3.1.1版本,感觉和安卓开发类似。在仿真设备运行时,提示“The type of the target device does not match the deviceType configured in the module.json5 file of the selected module.”,修改module.json5配置,加上了default,以及相应的仿真设备执行,错误依旧。搞不懂是什么原因。在官方论坛查找解决方案,未果。

有人知道是什么原因吗?


鸿蒙
仿真错误
type of the targ
2024-02-16 10:28:59
浏览
收藏 0
回答 2
待解决
回答 2
按赞同
/
按时间
轩秋夜雨

看下运行的模块module.json5配置里是否有你调试设备的设备类型,例如phone、tablet


分享
微博
QQ
微信
回复
2024-02-21 15:26:10
晒太阳的懒猫

加入了也没有作用。依旧报那个错误。感觉编译提示不是很友好、正确啊。

分享
微博
QQ
微信
回复
2024-02-22 11:44:20
相关问题
DevEco Studio快捷键怎么
5043浏览 • 1回复 待解决
关于DevEco Studio的gradle错误的处理?
15506浏览 • 4回复 已解决
DevEco Studio打开历史工程报空指针错误
3116浏览 • 1回复 待解决
使用DevEco Studio时Java预览器提示错误
7218浏览 • 1回复 待解决
DevEco Studio开发如何引入.so库
8443浏览 • 1回复 待解决
DevEco Studio 可以 安卓手机调试吗?
2749浏览 • 1回复 待解决
Deveco studio开发的APP怎么更改名称?
7202浏览 • 1回复 待解决