通过隐式Want拉起浏览器应用时报16000050错误

1. 华为浏览器,需要从1.2.0.3及以上版本才能支持隐式Want跳转。

2. 隐式Want拉起时,Want参数中不需要加上type信息。

3.Want这个网址链接是最左匹配原则,所以前缀不匹配也会报错。

HarmonyOS
2024-03-15 17:24:55
浏览
收藏 0
回答 1
待解决
回答 1
按赞同
/
按时间
elucky

1. 排查浏览器版本,是否支持隐式Want跳转;

2. 隐式Want拉起时,Want参数中去掉type信息;

3. 检查Want的网址是否为完整链接,需要包含http://前缀。

参考链接

使用隐式Want打开网址

分享
微博
QQ
微信
回复
2024-03-17 18:27:51
相关问题
浏览器应用应该怎样拉起
65浏览 • 2回复 待解决
有谁知道如何拉起浏览器应用
826浏览 • 1回复 待解决
拉起UIAbility时报16000050
824浏览 • 1回复 待解决
浏览器下载的文件如何导入鸿蒙
5782浏览 • 1回复 待解决
Web组件是否支持浏览器的localstorage?
503浏览 • 1回复 待解决
服务卡片webview如何跳转系统浏览器
6803浏览 • 2回复 待解决
安卓App或者浏览器如何跳转鸿蒙App
8717浏览 • 1回复 待解决
有谁知道ArkTS支持跳转吗?
760浏览 • 1回复 待解决