Context类型错误,报错401“The context must be a valid Context”

Context类型错误,报错401“The context must be a valid Context”

HarmonyOS
2024-03-17 12:07:55
浏览
收藏 0
回答 1
待解决
回答 1
按赞同
/
按时间
dickhome

401报错表示context无效,需要使用UIAbility的Context。获取UIAbilityContext的方式如下:

import { AbilityConstant, UIAbility, Want } from '@kit.AbilityKit'; 
export default class EntryAbility extends UIAbility { 
  onCreate(want: Want, launchParam: AbilityConstant.LaunchParam) { 
    let uiAbilityContext = this.context; 
    ... 
  } 
}

参考链接

应用上下文Context

分享
微博
QQ
微信
回复
2024-03-17 22:04:59
相关问题
如何在UI中获取Context
337浏览 • 1回复 待解决
是否支持Context跨线程传递
129浏览 • 1回复 待解决
如何在工具类中获取Context
125浏览 • 1回复 待解决
worker.ts中如何获取context
219浏览 • 1回复 待解决
Stage模型如何获取context?
2163浏览 • 1回复 待解决
鸿蒙中如何获取context对象
7033浏览 • 1回复 待解决
鸿蒙中页面的context如何拿到
15612浏览 • 3回复 待解决
请求广告返回错误401
122浏览 • 1回复 待解决
Ubuntu 升级问题 "401 Unauthorized"
908浏览 • 1回复 待解决
Socket连接报错错误码88
240浏览 • 1回复 待解决