鸿蒙安装应用失败:compileSdkVersion and releaseType of the a

发布于 2021-10-22 22:33
浏览
0收藏

报错信息

compileSdkVersion and releaseType of the app do not match the apiVersion and releaseType on the device.
鸿蒙安装应用失败:compileSdkVersion and releaseType of the a-开源基础软件社区

原因

鸿蒙工程的api版本比机器支持的版本高了。

解决方案

1、方案一、降低鸿蒙工程里的api版本
修改entry模块下的build.gradle文件中的compatibleSdkVersion版本号。
鸿蒙安装应用失败:compileSdkVersion and releaseType of the a-开源基础软件社区

2、方案二、找支持高版本的机器。
目前如果要支持Api 7,可以选择“P40 Pro”。(P40不支持)
鸿蒙安装应用失败:compileSdkVersion and releaseType of the a-开源基础软件社区

标签
已于2021-11-26 14:07:43修改
1
收藏
回复
举报
回复
添加资源
添加资源将有机会获得更多曝光,你也可以直接关联已上传资源 去关联
    相关推荐